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About this Manual

Welcome!

Documents
supplied

Congratulations, you have just purchased the world’s
leading automatic identification software package!

This label design software allows you to create and edit
complex labels—fast—and is capable of integrating all the
electronic data from across your company, guaranteeing the
full integrity of all your systems.

The application meets all your automatic identification
needs, and fits perfectly into your production process.

On today’s market, it is quite simply the MOST USER-
FRIENDLY AND INTUITIVE SOLUTION for any company
involved in complex barcode data entry, collection and
editing in real time.

Complete documentation is provided to help you make full
use of all the resources offered by your label design
software.

The Quick Start Guide takes you through product installation
and provides an introduction to the basic functions of the
software interface.

The Tutorial presents the basic concepts one by one,
helping you to get the very most from the software. A wealth
of examples enables you to put the ideas covered straight
into practice.
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The Tutorial

The documentation has been designed for use in
conjunction with the integrated Online Help.

The purpose of this manual is to get you off to a quick start
with the software by familiarizing you with its most common
functions, then covering the more complex functions by
means of examples of label creation.
The Tutorial is divided into six main sections :

« Discovering the interface

« Setting up the work environment

« Creating a document using fixed objects

« Creating a document using variable objects

« Printing

« Security and User Manager

The four appendixes provide detailed information and
examples on some of the more complex functions:

« formulas

* ODBC and importing data

* counters

 ActiveX

This manual outlines the best and most effective way of
carrying out specific tasks. For more detail on the different
functions, step-by-step procedures and reference
information, use the Online Help.

This manual has been designed to provide you with the
most effective help possible, whether you are a beginner or
an experienced user. The exercises are presented in
increasing levels of complexity, allowing you to save time by
moving directly to those at your level.

We recommend that beginners work through the
exercises step by step.

The examples provide a general approach to the many
functions. However, given the richness of the software,
they are not intended to be exhaustive.

The Tutorial is complimented by the Online Help, and is
by no means intended as a substitute for it.
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Typographical This manual distinguishes between different types of
conventions information by using the following conventions:

« terms taken from the interface itself, such as
commands, appear in bold;

« keys appear in small caps, as in the following example:
"Press the sHiFt key”;

* numbered lists mean there is a procedure to be
followed;

* when the conjunction "or” appears next to a paragraph
it means there is the choice of another procedure for
carrying out a given task ;

*« When a menu command contains submenus, the menu
name followed by the command to select appears in
bold. Thus, "Choose File Open” or “Go to File > Open”
means choose the File menu, then the Open command.

This symbol highlights important information about
!" how a particular command or procedure works.

for optimizing tasks, speeding up commands, and

Q Following this symbol you will find hints and tips
SO on.

This symbol indicates an introductory exercise for
@ you to work through.
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About your
product

Some of the functions described in this manual may not be
available in your product.

For the complete list of the specific features and functions
available in your software, please refer to the specifications
sheet provided with the product.



CHAPTER 1

Discovering the interface

Launching the program

1 Goto Start > Programs.

2 Select the name you gave to the program group when you
installed it (by default, it is the name of the application).

The main window appears on the screen.
Description of the main window
This section presents a general overview of the main

elements that make up the interface, as they appear in the
main window at the beginning of a work session.

Menu Bar The menu bar comprises eight drop-down menus: File,
Edit, View, Object, Datasource, Tools, Window and
Help.

To open a menu:
3 Select it with the left mouse button.

4 Then choose the required command.
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Workspace

Document

Status bar

Standard
toolbar

shortcut keys. Press ALT plus the key
corresponding to the letter underlined in the menu
name, then the key corresponding to the letter

Q To access commands via the keyboard, use the
underlined in the command name.

The workspace is the name given to the entire middle
section of the window, located between the graduated rulers
and the scroll bars. It includes the frame that sets the
physical limits of the document in which you will place the
objects to be printed, as well as a non-printable area where
you can insert comments or objects that you do not wish to
print.

When you open a new session, the program displays a
frame aligned with the top left-hand corner of the window.
This frame represents the physical limits of the document to
be printed. The objects that make up your document should
be placed inside this frame.

Located on the lower edge of the window, the Status bar
displays the name of the selected printer, the
communication port to which it is connected, the x and y
coordinates of the mouse pointer and the cx and cy
dimensions of the object selected.

Fera 25000 (I004h = o W DG BREE A e

Figure 1 The status bar

These tools allow you to execute routine tasks more quickly
than using the menus.

To select a tool:
 Click on the button corresponding to the tool.
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Figure 2 The standard toolbar

Text formatting These tools allow you to modify text and/or paragraph

toolbar formatting, i.e. change the font, character size, style options,
text wrap, and so on.

Text formatting

B ial

[
o
Mo

Figure 3 The text formatting toolbar

To change the formatting:
1 Select an object in your document.

2 Click on the required options.

All these options can also be accessed in the Text
Q dialog box by the command Object > Text...

Object These tools allow you to change the formatting of a selected
formatting object, i.e. place it in the background or foreground,
toolbar designate it printable or non-printable, lock or unlock it,

modify line thickness, or change the position of the barcode
human readable.

Obijsct farmatting

L TR RN N

Figure 4 The Object formatting toolbar
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To change the formatting:
1 Select an object in your document.

2 Click on the required options.

Object toolbar The Object toolbar displays the name of the selected object
and allows you to access its properties.

Textl

Figure 5 The Object toolbar

To access the object’s properties:
* Clickon &

View toolbar The View toolbar offers you a number of display options.

(& K 12 2

Q|

Figure 6 The View toolbar

To change the view mode:
 Click on the required view mode:

Name of tool Use

@ Name displaying variable names

Size displaying variables sizes. The space
occupied by the content of the
variable is represented by a series of
Xs.
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Name of tool Use

1z Contents displaying variable values

Form
%

displaying the Form

= Document displaying the Document Browser
| Fff=  Browser

Zoom allows you to enlarge or reduce
Q object detail.
Grid displaying the grid on the screen

n All these options can also be accessed via the
%" View menu.
¥

Design toolbar The creation toolbar comprises a number of buttons, each
one representing a tool for creating and manipulating
objects.

i
R |[TWME® FOO0G /O | &

Figure 7 The Creation toolbar

Name of tool Use

Selection tool selecting and manipulating objects
|T of all types
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T Text generation tool  creating fixed and variable text
Barcode generation  creating fixed and variable barcodes
|I.".|| tool
Image import tool inserting images
el
External object inserting objects external to the
OIE insertion tool application
| Line drawing tool creating horizontal or vertical lines
Rectangle drawing creating rectangles or squares
O tool
Circle or ellipse creating circular shapes
O drawing tool
Polygon drawing tool  creating free shapes made up of
= lines
Oblique line drawing  creating diagonals
« tool
Rounded rectangle creating rectangles with rounded
o drawing tool corners

Shapes Gallery tool

UCC/EAN 128 and
Maxicode wizards

Plug-ins

importing ready-to-use shapes into
the document

creating barcodes with the UCC/
EAN 128 and Maxicode wizards

Create Text Art, List Fields and Rich
Text Fields



Discovering the interface Chapter1-7

Document
Browser

The Document Browser contains two tabs: Data Sources
and Objects.The + and - symbols allow you to move up and
down the tree, and display the list of variables associated
with each data source or the objects available for each
category.

The Data Sources tab displays the data sources and the
number of variables associated. It allows you to insert
variable objects simply by dragging and dropping them into
your document. You can also add, delete and modify
variable properties using the context menu.

The Objects tab displays the number of objects created and
their properties by type, such as position, height and width.
You can select an object and modify its position in this tab.

i

g Databaze [Mone]
@ Date [Hone)

.----f{xJ Formula [Mone]
3% Fom [Mone)

ﬁ T able lookup [Mone)
Counter [Mone)
w2 Free [Mone)

Diata Sources IDbiects I

Figure 8 The Document Browser

About data sources

A data source contains a list of variables fed by data of the
same origin.
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Graduated
rulers

Rotation button

When you select a data source, you are indicating what type
of data is required and where it will come from. Data can be
of internal origin (Formula, Date, Counter) or external to
the application (Databases, direct keyboard input).

The different data sources available in the Document
Browser Data Sources tab are the following: Database,
Table lookup, Date, Formula, Form, Counter, and Free.

These display the position of the mouse pointer and allow
you to place the various objects included in your document
with total precision. They can be configured in inches or
millimeters using the Tools > Options... > Display
command.
¢ A double-click on the left half of the horizontal ruler
reduces the display scale.
« A double-click on the right half of the horizontal ruler
increases the display scale.
¢ A double-click on the vertical ruler displays the grid
selection box.

Zoom factor context menu by clicking on the
horizontal ruler, or the Orientation context menu
by clicking on the vertical ruler.

@ Using the right mouse button, you can display the

This button allows you to rotate the document on the
screen through 90°, 180°, 270° or 360°. Screen rotation is
merely a display feature, and has no effect on printing.

To rotate the document:
« Click on the rotation button with the left mouse button
to rotate the document through 90° to the left.
« Click on the rotation button with the right mouse button
to rotate the button through 90° to the right.

by choosing the View > Orientation command, or
by clicking on the vertical ruler with the right
mouse button to display the context menu.

Q You can obtain the same document rotation effect
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Color palette The color palette, displayed along the lower edge of the
workspace, allows you to modify the color of all your objects
(text, barcodes, shapes and black-and-white images).

Figure 9 The color palette

To change the color of an object:
1 Select an object in your document.

2 Click on a color in the palette with the left mouse button
to apply text, line or outline color.
_Or_
Click on a color in the palette with the right mouse button
to apply background color.

The button shown below allows object background
color to be removed

>

- The Online Help provides full information on
?‘ choosing the color palette, customizing it, and so
on.
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CHAPTER 2

Setting up the work environment

Before starting to create a document, you first need to set up
your work environment.

The first step consists in selecting the printer on which you
wish to print your labels. Not all printers share the same
characteristics and, as a result, different page setup options,
for example, will be available according to the model of
printer chosen.

The second step involves choosing your work environment
options, i.e. interface language, unit of measurement, and
so on. We will review all the options available later in this
chapter.

The final step consists of the document page setup, i.e.
defining the dimensions of the document, orientation,
margins, and so on.
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Choice of printer

Selecting the
printer

Adding a printer

Your label design software allows you to print on a wide
range of printers, the drivers for which are supplied with the
software. You can also print on any Windows printer
installed locally on your machine or on your company’s
network.

You must select the printer before you begin creating your
document as the choice of printer will determine page setup
options, the use of different character fonts, and so on.

The Printer selection dialog box can be accessed using the
File Select printer... command, by the % button or by
pressing rs.

It can also be accessed via the Printer... button in the Print
dialog box (F6 key).

To select a printer:

1 Click on the %
- Or -
Go to File > Select printer...

You can also press the F5 key.

2 Select the printer from the list, then click on OK.

The printers drivers provided by the application are
indicated by the following icon:

i

The Add printer dialog box is accessed using the File
Select printer... command, then by clicking on Add...

This dialog box allows you to add the printer drivers supplied
with the software.

To add a printer:

1 Goto File > Select printer...
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You can also click on the & button or press the F5 key.
2 Click on Add...
3 In the Model list, select the make then model of printer.

4 Select the communication port (serial, parallel, file or
network), then click on OK (see Printing).

Click on the + sign next to the make of printer to
@ display the different models.

Customizing the work environment

Your software offers a number of options for customizing
your work environment.

Modifying Options include the choice of language interface, units of
display and measurement, dialog box display font, working folders, and
work currency conversion rate.

environment
options These choices are made in the Options dialog box.

To access this dialog box, choose Tools > Options...

To change the interface language:
1 Goto Tools > Options...
2 Click on the Display tab.

3 Select the required language, then click on OK.

Once you click on OK, all the menus, commands and
screen messages will appear in the selected language
(except the Online Help and the Windows dialog boxes
such as Open, Save, and so on).
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To choose a unit of measurement:

1 Goto Tools > Options...

2 Click on the Display tab.

3 Select the unit, then click on OK.

To change the dialog box display font:
1 Goto Tools > Options...

2 Click on the Display tab.

3 In the Display font area, click on _I
4 Select the font and size, then click on OK.
To modify the grid scale:

1 Goto Tools > Options...

2 Click on the Grid tab.

3 Select the required grid scale.

4 Select the Display option, then click on OK.

Advanced tip!
Q Double-click on the vertical ruler to access the

Grid tab directly.

To define a conversion rate:
1 Goto Tools > Options...
2 Click on the Others tab.

3 Enter the conversion rate in the box, then click on OK.
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The default conversion rate is between the French
Franc and the Euro. To change to a different currency
system, simply enter the corresponding rate.

The conversion rate defined in the box is the one used
in the eurotocurrency and currencytoeuro formulas.

To define a working folder:
1 Goto Tools > Options...
2 Click on the Default folders tab.

3 Inthe File type list, select the type of file for which you
wish to define a new default folder.

4 Enter the new access path or click on Browse...
5 Enter or select the access path for the new working folder.

6 Repeat this procedure for each file type as required, then
click on OK.

Document Page setup

Document page setup consists of specifying the page size,
orientation, number of documents per row and per column,
document size, margins, and distance between documents.
You can also create customized stocks and save them for
future use.

Document stocks are created and modified using the Page
setup dialog box.
« To access the Page setup dialog box, click on %
_Or_
Go to File > Page setup...
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Saving a
customized
stock

Before creating a document stock, you must first
choose the model of printer that will be used to print the
document. Page format is defined using the Page setup
dialog box, which also updates the printer settings. The
page settings defined here will override those
previously defined in the Printer setup dialog box.

Once you have finished defining your stock, you can then
save it for future use. Stocks are managed by saving them
under different categories, in much the same way as the
folders in Windows Explorer. Saving stocks in this way
makes them much easier to relocate.

To save a customized stock:

1 Goto File > Page setup...
_or-

Click on the EE" .

2 Configure the format.

3 In the Stock tab, select a type from the Type list, or enter
anew one.

4 Select a stock name from the Name list, or enter a new
one.

5 Click on Save.

If you are not happy with the settings you have made,
just click on Remove. The program closes the Page
setup dialog box without saving the changes.

On the other hand, the predefined stocks supplied with
the application cannot be modified.

Page tab, your document is automatically sized to

By selecting the Automatic Sizing Box in the
; the selected printer’s default.
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Designing a CD sleeve: page setup and
creating a customized stock.

1

2

3

Create a new document and call it FRONT.
Select the printer.

Goto Tools > Options..,, click on the Display
tab and select Millimeters as the unit of
measurement. Click on OK.

Go to File > Page setup...
_Or_

Click on the @ .

Click on the Label tab and enter the following
values:

Width and Height: 120,

Corner roundness: 100,

Number of labels:

Perrow: 1,

Per column: 2.

Click on the Page tab and select the following
values:

Page size: A4,

Portrait.

Click on the Margins tab and enter the following
values:

Margins:

Left: 40,

Top: 10,

Gap:

Between rows: 15.

Click on the Stock tab and enter the following
values:

Type: Jaquette,

Name: CDx2.

Click on OK.
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Removing a
customized
stock

Using a
personal stock

The printer used in this example is a Windows™ printer.
If you wish to use a thermal printer, it may be that error
messages will appear during page setup. You will thus
need to modify the values suggested in the example
because, as we have already seen, the choice of printer
affects certain settings.

When a stock you have created is no longer needed, you
can remove it.

To remove a customized stock:

1 Goto File > Page setup...
_Or_

Click on the EE.-"I .

2 Inthe Stock tab, select the type to be removed if you wish
to remove the type and all the stocks it contains.
_Or_
Select the individual stock to be removed.

3 Click on Remove.

You can design a personalized stock using a drawing tool to
be used as a label stock for printing. To do so, you must
save the stock as an EMF file and save it in C:\Program
Files\TKN\8\Common\LFM. Once it has been saved in the
LFM folder, you can access it from the Page Set up dialog
box by going to the Stock tab and selecting the Type and
Name of the file from the drop-down menus.

name of the file should include the Type and the
Name of the stock. i.e.: SD DVD Labelx2.emf
This will allow you to select SD from the Type
drop-down menu, and DVD Labelx2 from the
Name drop-down menu.

! When saving an EMF file, remember that the
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Creating a document using fixed
objects

Creating and manipulating fixed objects

Creating fixed objects involves inserting objects such as

text, barcodes, images, lines, rectangles and circles into

your document.

» Use the creation tools to add objects to your document,
and the Object menu commands to define their default
properties.

Each object created is automatically given a name by
the application. When the object is selected, its name
appears in the Document Browser’s Objects tab, and in
the Object toolbar.

Creating a A Text object can be one character, one word or an entire
Text object paragraph.
Character style and paragraph format can be defined using
the Text formatting toolbar or the Text dialog box.

To create a Text object:

1 Click on the Text generation tool.
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2 Click inside the workspace or on the text to be modified.
_Or_
Click and draw a frame within the workspace.

A flashing cursor indicates the location of the next character.

3 Enter your text.

@ Creating a CD sleeve: inserting text
1 Click on the Text generation tool.
2 Click inside the workspace and type "Volume:”.
3 Select the text then double click on it.
4 Enter the following values:
Font: Arial,
Height: 10 points.

5 Click on OK.

6 Repeat the above procedure to insert the text
"conducted by:".

To position the ”"Volume:” and "Conducted by:"
objects:

1 Select one of the Text objects in the document.
2 Click on the Objects tab in the Document Browser.
3 Using the mouse, open the branch of the tree marked with

a red arrow (pointing to the object selected in the
document).
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Figure 10 Text properties accessible in the tree

For the Text Select Press the F2 key,
object... then enter...

"Volume:” the x coordinate:  “10”
the y coordinate:  “40”

"Conducted the x coordinate:  “10”
by:” the y coordinate: ~ “50”

4 Select the two Text objects and click on the Lock button.

Unicode can be used to create labels using a
* variety of linguistic characters. To use Unicode,
¥ just select a Unicode font for your text by going

to the Character tab available in the Properties of
your text object.

Creating a Your software offers a wide range of symbologies adapted
Barcode object to the requirements of the industry, as well as the option of
creating 2D barcodes.
Selecting the symbology, defining its attributes and entering
the message to be encoded are carried out using the
Barcode dialog box.
* To access the Barcode dialog box, go to Object >
Barcode...
_Or_
Press the rs key.
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Creating a
shape object

To create a Barcode object:

1 Click on the Barcode generation tool.
2 Click inside the workspace.

The Barcode dialog box appears.

3 Select the required barcode in the Code tab. You have
the choice between Printer and Graphic.

4 Click on Printer to display the list of barcodes resident on
the selected printer.
_Or_
Click on Graphic to display the list of barcodes
generated by the software.

Some printers do not possess resident barcodes. The
Graphic option is used to print barcodes on these
printers. However, since such barcodes are sent to the
printer as graphic files, this tends to slow printing
down.

5 If necessary, specify the characteristics of the barcode
(height, narrow bar width, ratio, check character, and so
on).

6 Enter the data to be encoded in the Data box, then click
on OK.

Your software comes complete with a range of tools to help
you design perfect labels.

To draw a line:
1 Click on the Line drawing tool.
2 Click inside the workspace.

3 Holding down the left button, move the mouse horizontally
or vertically.
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To draw an oblique line:
1 Click on the Oblique line drawing tool.
2 Click inside the workspace.

3 Holding the left button down, move the mouse diagonally.

To draw a rectangle:

1 Click on the Rectangle drawing or Rounded rectangle
drawing tool.

2 Click inside the workspace.

3 Holding the left button down, move the mouse diagonally.

Draw a square, the sHIFT key while you move
the mouse.

draw a rectangle the cTrL key while you move

centered on the starting  the mouse.

point,

To draw a circle or ellipse:
1 Click on the Circle or ellipse drawing tool.
2 Click inside the workspace.

3 Holding the left button down, move the mouse horizontally
until the required shape is achieved.

Draw a circle, the sHIFT key while you
move the mouse.
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draw an ellipse centered the cTrL key while you move
on the starting point, the mouse.

@ Creating a CD sleeve: drawing a circle
1 Click on the Circle or ellipse drawing tool.
2 Click inside the workspace.

3 Holding the left mouse button down and
pressing the SHIFT key, move the mouse
horizontally to create the required shape.

4 Select the circle and choose Properties... in the
context menu.

5 Click on Position/Size...and enter the following
values : Width and Height: 20. Click on OK.

6 Go to Object > Layout > Horizontally
centered in document then Vertically
Centered in Document to align the circle with
the center of the sleeve.

7 Select the circle then click on the Lock button.

To draw a polygon:
1 Click on the Polygon drawing tool.
2 Click inside the workspace.

3 Construct the required shape by clicking and moving the
mouse.

4 Double-click to finish the shape.
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To close the polygon, double-click on the starting
@ point. You can now add a background color.

Importing an Your software allows you to insert images and company
image logos to help you perfect your label.

A number of formats can be imported: bmp, dib, rle, dxf, eps,
fmf, img, jpg, pcd, pcx, dcs, png, tga, tif, wmf and wpg.

To import an image:

1 Click on the Image import tool.
2 Click inside the workspace.

The Open dialog box appears.

3 Select the image file to be imported in the Document
Browser or Gallery tab, and confirm.

To help you find the image to be imported, display
Q the file preview by clicking on .
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@ Creating a CD sleeve: inserting the logo
1 Click on the Image import tool.

2 Click inside the workspace.

3 Using the Open dialog box, select the
LOGO.BMP file located in the software
installation folder: \TUTORIAL\IMAGES. Click

on OK.

4 Select the logo then enter the following values:
x: 90 and y: 60.

5 Lock the logo.

Your label should now look like this:

[ 1o =] |30 |40 |50 s 70 |20 a0 |10 |11
T A R O T i e O e

Yolurne:

Conducted

Figure 11 The example label

6 Save your document.

To finish this example, refer to Appendix 2 -
Connecting to databases.
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Creating Text
Art

Text Art allows the user to change text characteristics such
as outline color, and bend angle. Unsing Text Art, a text can
be placed on a circle. The arc of the circle used to draw the
text can be defined from 0 to 360 degrees. The angle of the
start position can also be adjusted. This is useful for CD/
DVD labels, for instance.

To create a Text Art object

1 Clickon B icon from the creation toolbar and choose
TextArt from the options menu.

2 Drag itinto your label
3 Double-click on it or go to Properties in the context menu

4 Go to the Shape settings tab and select the background
shape to which the text will be bent to.

i.e.: for a CD label, select ellipse

5 Select a Border color and Background color to the
shape, if you wish.

6 Go to the Text settings tab and select the font size and
type for the text.

Type your text in the text box
- Or -
Select a data source.

7 You can select the Border, Fill and Shadow color (and
width) for you text

8 Select the bend angle by writing in the start and end angle
for your text

- 0r -

Drag the circle’s handle around until you have selected
the bend angle for your text

9 Choose how you would like to align you text (left, center,
right, letter justified or word justified) as well as the
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Creating a List
Field

character spacing and whether the characters should be
bent.

10 Click OK to view the result.

List field is used to spread data in a table. It has been
designed for companies who need to create Order or
Invoice documents. List field can be used in connection with
bridging softwares that provide complex data from external
sources (any ERP or Legacy systems).

To create a List Field object
1 Click onthe B icon in the creation toolbar
2 Select List Field from the options menu

3 Add a Free variable by right-clicking on Free in the
Document Browser and selecting Add

- or -
By going to Datasource > Free > Add in the menu.

4 In the Input tab, choose Select a File and browse for the
file containing the data that will be appearing in the List
Field.

5 In the Output tab, set theMaximum length to 999 or any
other value of your choice

6 Click OK
7 Double-click in the List Field

_Or_

Right-click in the List Field and select Properties from the
context menu

8 In the List Field tab
« Set the font, size and color of the text
 Select the Datasource from the drop-down menu

* Define the Control characters as in the linked
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Creating a RTF
Field

document

9 Goto List Field Columns tab and Add as many columns
as are in the datasource file

10 Set the parameters of each column by clicking on a line
and editing the fields below.

11 The background and border settings can be changed in

the Shape settings tab (see Setting Shape Parameters
on p. 3-30)

Rich Text Field Objects are used to manage RTF
information such as chemical formulas (H,O), or scientific
expressions (y=x?). The object can be linked to a database
or external file containing RTF (the data can be fixed or

linked). For fixed data, an RTF editor is provided, but any
other RTF supporting editor can be used (i.e.; MS Word).

To add an RTF object

1 Clickonthe [ icon available inthe creation toolbar, and
select it from the option menu.

2 Double-click on the RTF object

-or-

go to Properties available in the context-menu.
3 Select the Rich Text Field tab

4 Select a Data source (if applicable)

5 Click on Edit Text to enter your text

Use the R icon to elevate a typed letter or
Q character and the % to strike out any character.

6 Click OK
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Setting Shape
parameters

Setting the
Object Order

It is possible to set the parameters of shapes such as line
style and fill pattern.

To set shape parameters
1 Double-click on a shape object
_Or_

Go to Properties available in the context menu of the
selecte shape object

2 Select the Shape settings tab

To set the fill pattern

1 Checkmark the Background checkbox
2 Select a color and/or pattern

3 Set theinternal margin - this is the space available
between the fill color and the border

To set the border settings

1 Select a color and/or pattern

2 Select a Dash Style from the drop-down menu
3 Select the Dashcap from the drop-down menu

4 Select the Border Width

OLE embedded objects will also have the
capability to select a shape for the background

Q Other objects such as Text, Barcode, Image, and
and apply tine style and fill pattern.

Placing label objects in a particular order is done by using
the Object Order dialog box. This feautre is especially
useful when objects need to be sent to a printer in a specific
order or for printers working in a stand-alone mode who are
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waiting for external data in a specific order.

To order objects in a label
1 Goto Objects > Order...

A dialog box will pop-up with a list displaying all currently
available objects.

2 Select an object and move it up and/or down using the up/
down arrows.
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CHAPTER 4

Creating a document using
variable objects

Variables

Definition

Data source

Database

Your software allows you to create variable objects, the
values of which can be fed by different data sources. The
value of these objects, whether Text, Barcodes or Images,
advances during printing.

A variable is a non-physical object, the value of which
advances during printing. A variable can be fed in a number
of different ways:

« by data extracted from an external database,
« by an external application,

« by data entered via the keyboard,

« by data calculated by the computer or printer.

Your software distinguishes between the different
categories of data according to their source. You can thus
create variables using a number of different data sources.

A variable created using the Database data source is fed by
data contained in one of the fields in the database merged
with the current document.
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To create Database variables:

Before a Database variable can be created, the current
document must first be connected to the database.
According to your requirements, you can connect to a
database using either ODBC, OLE DB or by directly
importing an ASCII table.

First: install the ODBC data source drivers on your
computer. Then install the data source, specifying the
database engine and the name and access path of the
database to be connected.

Connecting to a database using ODBC
1 Goto Data source > Databases > Create/Edit query...

2 In the Select a data source list, select the ODBC data
source already installed.

3 Select the table(s), then the fields you wish to work with.
Click on OK.

The variables are created automatically.

that will actually be used in your document. This
reduces the amount of data exchange with the
base, thus increasing processing speed.

Q You are recommended to select only those fields

To import an ASCII table

1 Goto Data source > Databases > Open ASCII table...
2 Enter the name of the data file (*.txt).

3 Enter the name of the descriptor file (*.dsc).

4 Click on OK to import the ASCII table.

The variables are created automatically.
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Table lookup

; The Online Help contains all information relating to
?’ data file structure and defining a descriptor file.

The Table lookup data source contains a list of variables
created as and when you need them. The variable values
are the result of searches carried out in databases other
than those linked to the current document.

Searches are carried out in one or more fields of a table in
the database. The data is extracted from one of the record
fields found (called the "result field”).

To create a Table lookup variable:

1 Select Table lookup in the Document Browser’s Data
Sources tab.

2 Choose Add...in the context menu.

The variable created appears automatically within the
selected data source.

A new sub-branch specifying the name of the data
source is automatically created within the Table lookup
branch. A new sub-branch is created automatically
each time a Table lookup variable is created with a
result field derived from a different database.

To define the properties of a Table lookup variable:

1 Select the Table lookup variable, then choose Variable
properties... in the context menu.

2 Inthe Select a data sourcelist, select the ODBC or OLE
DB data source in which you wish to search for the field,
the resulting data of which will populate your Table lookup
variable.

3 In theSelect table list, select the table in which the search
is to be carried out.



Chapter 4 - 30

Tutorial

Date

4 In the Select result field list, select the field, the value of
which will be transferred to your variable.

5 Define the search conditions by selecting the table field(s)
in which theKey field column searches will be carried out.

6 In the Key value column, select the current document
variable(s) containing the search values.

The variable containing the search value must be
created before the variable that will use it. When several
table records meet the condition, it is the first one
encountered that will be displayed.

7 Click on OK.

The Table lookup variable is given the same name as the
table selected.

The appendix entitled Connecting to Databases
@ at the end of this manual provides an example of
creating a CD sleeve. The example describes
how to install an ODBC database, import data
from a database using ODBC, create a Table loo-
kup variable, carry out complex queries, and so
on.

The Date data source contains a list of variables created as
and when you need them. These variables are fed by the
computer or the printer's system date. They allow the date
and time to be displayed, according to a predefined format.
The value is updated automatically at the beginning of each
print series.

You can insert the current date and/or time into a document,
you can also add a fixed value to it.

To create a Date variable:
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Counter

1 Select Date in the Document Browser’s Data Sources
tab.

¢ Choose Add... in the context menu.

The variable created appears automatically within the
selected data source.

To define the properties of a Date variable:

1 Select the Date variable, then choose Variable
properties... in the context menu.

2 In the Datetab, select the desired date format (day of the
week, month, etc.) from the drop-down list. You may also
create a user-defined date format by selecting
Customized from the drop-down list.

3 A box in which you can configure a user-defined date
format is displayed.

4 You can view the selected date format at the top of this
dialog box.

5 Click on OK.

If you wish to display the time in your document, repeat the
above process by selecting the data source from the drop-
down list. You can also concatenate the date and time in the
same variable.

appendix 1 at the end of the manual provides an
@ example of creating Date variables.

The Counter data source contains a list of variables created
as and when you need them. These variables are fed by
data calculated either by the computer or your printer.

The content of the variable changes as printing advances,
according to an initial value and an increment value.
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To create a Counter variable:

1 Select Counter in the Document Browser’s Data
Sources tab.

2 Choose Add...in the context menu.

The variable created appears automatically within the
selected data source.

To define the properties of a Counter variable:

1 Select the Counter variable, then choose Variable
properties... in the context menu.

2 Choose between a Shared variable counter and an 1ISO
counter. Check the Shared Variable box if you want to
be able to reuse this variable in other documents.

3 Select the type of counter.

4 Enter avalue inthe Increment box. The defaultincrement
is +1.

5 Enter a start value in theMin value box. The default value
is 0.

6 If you have selected a Shared Variable counter, you can
reset the counter after a variable value has changed by
selecting the Reset after variable value change check
box and selecting the variable from the drop-down list.

7 Click on OK.

At the end of the manual there is an appendix
@ entitled Counters which describes a wide range
of example labels containing counters and
demonstrates how to fine tune counter properties,
set up complex, customized and linked counters,

and so on.
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Formula

Form

The Formuladata source contains a list of variables created
as you need them. These variables are populated by
combinations of operators, constants, variables, control
variables, formulas and functions. Data can be either
numerical or alphanumerical.

To create a Formula variable:

1 Select Formula inthe Document Browser Data
Sources tab.

2 Choose Add...in the context menu.

The variable created appears automatically within the
selected data source.

To define the properties of a Formula variable:

1 Select the Formula variable, then choose Variable
properties... in the context menu.

2 Enter the formula directly in the edit box.
_or-
Select the elements of your choice with the mouse, then
click on Insert.

Advanced tip!
Q You can insert an element simply by double-clic-

king on it.

3 Click onTest to verify that the syntax is correct. If an error
occurs, follow the instructions displayed on the screen
and carry out any necessary changes.

4 Click on OK.

The Form data source contains a list of variables created as
and when you need them. These variables are fed by
entering data directly into the Form via the keyboard.
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If the name of a variable used in the formula con-
!' tains any of the following characters: &+-*/
<>="0,I\", the name must be enclosed in {}s.

At the end of this manual is an appendix entitled
@ Formulas offering a wide range of example labels
containing formulas. The examples demonstrate
how to fine tune formula properties, set up com-
plex formulas, calculate specific "modulos”, and

SO on.

To create a Form variable:

1 Select Form in the Document Browser’s Data Sources
tab.

2 Choose Add...in the context menu.

The variable created appears automatically within the
selected data source.

To define the properties of a Form variable:

1 Select the Form variable, then choose Variable
properties... in the context menu.

2 Click the Input tab. Check the Shared box if you want to
be able to reuse this variable in other documents.

3 Click the Form tab to define the characteristics of your
variable.

4 Enter the prompt text you want to display on the form in
the Prompt field.

5 Enter an input syntax (for example: ##-##-## if it is a date
that will be entered).

6 In the Minimum Length box, enter the minimum number
of characters that must be entered for the text to be
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validated.

7 If you check theForce data to come from the list box, it

will be impossible to enter data directly in the box on the
form.

8 The Pick List box contains values you can use when
completing the form. The following dialog box is

displayed:
Pick list x|
List name I vl ¥ shared
|Values %““E|‘X|f|¢|

¥ Selection as default

OF I Cancel | Help

This dialog box contains two options:
« creating values,
« or use pre-defined lists of shared values.

You can also display a default value in the text box of the
form. To do so, check the Selection as default box.

9 Click on OK.

The Form

The Form allows you to enter data directly.

It is possible to change the appearance of the form and
make it more readable by changing the color, adding
borders or changing the font, and so on. The customized
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form will be saved with your document.

« To access the Form, go to View > Mode > Form.
_Or_
Click on the Open form button on the View toolbar.

« To change the appearance of the Form, click inside the
Form and choose Customize from the context menu.
_Or_
choose Format cells... to change the color, style, form
borders, and so on.

provided in the on-line help system. This allows
you to access all shared variables classified as
free, counter or pre-defined form variables.

? Information on the Shared Variables Manager is

The Form customization dialog box offers the following
options:

Display rows displays the rows.
Display row displays the row numbers. In
headers conjunction with Enable row

moving, this option allows you to
change the order in which data
appears in the Form.

Select the number of the row to be
moved, then drag the mouse to the
new location.

Lock form prevents modification, moving,
resizing or deleting of rows.

Distribute rows adjusts row height to the minimum

evenly necessary to display the tallest row.
Enable row allows rows to be moved within the
moving form, providing the Display row

headers option is activated.
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Free

Display form offers three options that come into

when printing effect when printing is launched:
- No: the Form will not be displayed.
- For each label: the Form will be
displayed for each label in a print run.
- For each series: the Form will be
displayed once at the beginning of a
print run.

The Free data source contains a list of variables created as
and when you need them. A variable is called Free if the
origin of the data that feeds it is not specified.

To create a Free variable:

1 From the Data Sources tab in the Document Browser,
select Free.

2 Choose Add... in the context menu.
To define the properties of a Free variable:

1 Select the Free variable, then choose Variable
properties... in the context menu.

2 Select one of the following options: Local or Shared.

; The Online Help further information on shared
?' variables.

3 If you have chosen the Local option, enter the variable
value in the box. This is the initial value of the variable, the
one that will be printed first.

_Or-

If you have chosen the Shared option, click on the =
button if you need to modify the current value of the
variable. Click on OK.

4 Click on OK.
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Specific examples of using Free variables can be
found in the Formula and Connecting to Data-
bases appendixes.

Variable objects

Creating
variable objects

The previous chapter introduced the concept of objects. We
are now going to take this one stage further and look at
variable objects.

A variable object is a variable that takes on a physical
appearance, whether text, barcode or image. Thus, the
value of any variable from any source can be displayed in
your document in the form of text, or encoded in a barcode.

Moreover, several objects can be associated with a single
variable.

Creating a variable object involves associating an object
with a document variable.

There are two ways of creating variable objects:
« creating a variable object from a fixed object ;
« creating a variable object using a creation tool.

To create a variable object from a fixed object:

1 Select a Text object in the document (the whole object
must be highlighted).

2 Select Properties... in the context menu.
3 Click on the Data source tab.

4 Select the Variable data option, then select the data
source that will feed the variable object.

5 Click on OK.
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Do not forget to click the Display field contents
@ button to view the variable values.

To create a variable object using a creation tool:

1 Click on the Text generation, Barcode orImageimport
tool.

2 Select the variable you wish to associate with the object
in the Document Browser's Data Sources tab.

3 Drag and drop the variable to the required place in the
workspace.

The variable object thus created displays the name of the
associated variable.

4 To display the variable value, click on the Display field
contents button

Advanced tip!
; 1 Select the variable you wish to associate with

the text object in the Document Browser’s
Data Sources tab.

2 Drag and drop the variable to the required place
in the workspace.

A context menu appears, listing the different
objects.

3 Select the required object.

The variable must be created before the variable object
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Interchanging two variables:

To replace a variable already inserted into your
document with another variable:

- Select the variable to be replaced, then the select
the substitute variable in the Document Browser.

- Drag and drop the new variable onto the one to
be replaced.

The new variable appears instantly.
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A powerful print engine

Traditional
printing

Your software is both a powerful, user-friendly creation tool
and a print engine, bringing together the widest possible
range of printers (thermal, thermal transfer and inkjet), never
before available on the automatic identification market.

A number of solutions are available for printing your
documents: individually, in batches, and so on.

Whether printing a single label, a series of labels, or multiple
copies of the same label, all print settings are made using
the same dialog box: Print.

1 Goto File > Print... or click on % or press the F6 key.

The Print dialog box appears on the screen
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Figure 12 The Print dialog box - basic

Figure 13 The Print dialog box - expanded

2 Click on Print.

The current label (the one displayed on the screen) is
printed.
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If the document includes a counter, the number entered in
the Labels field allows you to determine the number of
different labels to be printed, i.e. the number of counter

increments.
If your document does not contain a counter, you
!' can print multiple copies of the same label by

entering the required number in the Copies of
each label field.
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Practical Workshop 1 - Label Series and Label

Copies

Labels in the
series

To start, let’s distinguish between Labels and Copies of
each label.

If the label does not include a counter, the Print dialog
box will not display the Copies of each label field, but
only the Labels field, which in this case serves the same
purpose.

To highlight the difference between Labels and Copies of
each label, we shall consider a label containing two types
of counters, and configure the Print dialog box in different
ways.

* Open the TuTORIAL\LABELS\COUNTER.TPL label.
This is a simple label containing two different counters:
 a classical counter that counts all labels, and resets
when its value reaches 10:
- Type
- Increment +1
- Min value 0
- Max value 10
e an ISO counter allowing each label copy to be
individually and exhaustively numbered. It also resets
when its value reaches 10:
- Type
- Increment +1
- Min value O
The first counter, called NumLabel, identifies a particular

label, whereas the 1SO counter counts the total number of
labels printed.

In this example, we are going to print a series of 10 labels:

1 Enter the following values in the Print dialog box:
Labels :10.
This means that there are 10 different labels in the series.

2 Click on Print.
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Copies of each
label

Copies of each
page

The printed output is as expected: 10 labels have been
printed and the two counters read the same value.

Here we will print a series of five labels, but this time we
want two copies of each one.

1 Enter the following values in the Print dialog box:
Labels: 5
Copies of each label : 2.

2 Click on Print.

10 labels have been printed, however the result is totally
different from the one obtained in the last example.

Mumabel: 0 MNum abel: 0 MNumlabel: 1 urm Label: 1 urmLabel: 2
150 Count: 0 150 Court: 1 150 Court: 2 50 Court: ¥ 50 Court: 4
um Label: 2 um Label: 3 um Label: 3 um Label: 4 urm Label: 4
50 Court: 5 10 Court: & IF0 Court: 7 S0 Court: 2 S0 Court: 9
= The |50 counter numbers
Label copies the total rumber of labets pinted.

Figure 14 The printed output

As we have just seen, it is possible to print multiple copies
of the same label. In the next example, we will see that it is
also possible to print multiple copies of the same page. We
therefore need to know exactly what the printer understands
as being a page.

The page is determined by the parameters specified when
the printer driver is configured. The results obtained may be
completely different depending on whether you print on an
office printer or a thermal printer. It can be quite difficult to
visualize a page on continuous paper, as used mainly by
thermal printers.
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Moreover, according to the dimension of the print media and
the size of the label, the page dimensions may correspond
to those of the label, and thus, by extension, the page copy
may be the same as the label copy.

The page format and label size are defined in the Page
setup dialog box.

1 Open the TuTorIAL\LABELS\CouNTO1.TPL label.

2 Goto File > Select printer...

3 Select a Windows office printer.

4 Make sure that the paper format is A4, then click on OK.
5 Goto File > Page setup... or click on EE’

The Page setup dialog box appears.

T
Stock. | Label | Page | Margins | PFTac |
Type -
Hame [k B

Preview

Number of abels : 2x3

Label size : £0.00 x 60,00
(mm)

Page size a4

Camment

Save Remove I

|Tup margin too small |

Settings... I o I Cancel Help |

Figure 15 The Page setup dialog box

The preview gives you an idea of how the page will look
when it is printed.

6 Close the dialog box.
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7 Clickon B

8 Enter the following values:
Labels: 8
Copies of each page: 2

9 Click on Print.

The result is as follows:

Humlabel: 1 Humlabeal: 3 Hurm Label: 1 Humilabel: &
Numlabel: 3 MNum Label: 4 Murmn label: 3 Mum label: 4
Mumlabel: § Num Label: & Murm label: § MumLabel: §
Numlabel: 7 MNumn Label: & Hurn label: 7 MNum Label: &

Warning! The same label printed on a thermal printer using continuous
paper may give a completely different result,

Figure 16 An example of printed output

If your label contains an ISO counter, Page copy
' will be the same as Label copy.
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Practical Workshop 2 - Print Merge

Print merge

Print Merge is only available if your label is linked to a
database (ASCII or ODBC).

The Merge function prints all the records contained in the
database.

1 Open the TuToORIAL\LABELS\IDENTITY.TPL label.

2 Make sure that the connection with the
Librairies\Databases\identity.mdb database is properly
established.

3 Goto File > Print... or click on % or press the F6 key.

The Print dialog box appears.

4 In the Records section, Check the All records box.

All records in the database are printed, i.e. three labels.

If you do not see the ‘Records’ section, click on the
MORE >> button to expand the dialog box view and
display more setting options.

Practical Workshop 3 - Printing using the form

Customizing the
form

It is often the case that variable data needs to be entered by
an operator just prior to printing. Your application offers a
quick and simple method of data entry: the Form.

You are free to customize forms by choosing the
background and border color for each cell in the grid, font
type, font size, and so on.
1 Open a new document.

2 Add a variable using the Form data source in the
Document Browser.

3 Rename it NamE (F2 key), then double-click on it.
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Prompt<

4 Complete the dialog box with the following information:
- In the Form tab, type “Name” in the Prompt field.

5 Click on OK.

6 Repeat the above procedure to create a variable called
ID. Complete the dialog box with the following
information:

- In the Form tab, type “ID” in the Prompt field.

7 Insert them into your document.

8 Display the Form either by going toView > Mode > Form,

or by clicking on % OF by pressing F4.

The Form appears, as shown in the figure below:

Name:

/

> Data entry cells.

\

Borders are not displayed by default. The dotted lines
mark the different cells in the Form.

Figure 17 The default Form

9 Select a cell and display the context menu (right mouse

button).

The following two commands are displayed: Format cells...
and Form customization...

Format cells allows you to define:

« the font type and color for displaying the prompt;
« the cell background color;

« cell border color;

« text alignment with the cell.

« Set the above options as required.
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Printing using
the form

Form customization allows you to:

« display row headers (when row headers are displayed,
you can select an entire row and change its position);

« display the form as a grid,;

« configure the way the Form behaves, i.e. whether it is
displayed For each label or For each series. For the
purposes of our example, select the For each label
option for both variables.

Now that the Form looks the way you want, we will launch
printing.

1 Goto File > Print... or click on % or press the F6 key.
2 Enter "2” in the Labels field.
3 Launch printing.

The form is displayed, and you are invited to enter the data
to be printed.

4 Enter "Smith” and "51”, for example, then click on OK.
Once the first label is printed, the form is displayed again.

5 Enter "Mullang” and 52", for example, then click on OK.

The Form is displayed for each label contained in the
series. If you choose the ‘For each series’ option, the
Form will only be displayed once, when printing of the
label series is launched.
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To sum up...

The Print dialog box

contains differences...

Copies of each page

Print Merge

Printing using the
Form

When the label contains a counter:

Labels allows you to specify the
number of different labels in a series;
Copies of each label allows you to
determine the number of copies of the
same label to be printed.

When the label does not include a
counter, this option serves the same
purpose as the Labels field.

A page copy can only be carried out if
the label does not include an ISO
counter and if the page contains more
than one label.

This option prints all the records in a
database, and is only available when
the label is connected to a database.

The Form allows an operator to enter
data by keyboard just prior to printing.

Practical Workshop 4 - Printing an RFID Label

An RFID label can only be printed if an RFID printer has

been selected.

Setting up an

RFID print job
_Or_

1 Click th Printer Selectionicon

2 Goto File > Printer Selection

3 Select an RFID compliant printer

4 Click OK

5 Click on the Page Setup icon
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RFID label
example

-or-
6 Goto File > Page Setup

7 Click the RFTag tab

8 Select a tag model from the drop-down box
9 Define the values for each parameter

10 Define the data structure by setting the Value, Access,
Datasource, Lock/Unlock, Verified/Unverified (See
the Online help for a detailed description of each field)

11 Click on Print

We will reproduce the RFID.lab label found in C:\Programs
files\ CODESOFT 8\Samples\Labels.

1 Open a New document by going to File > New or by
clicking on the New document icon

2 Select an RFID compliant printer by going to the Printer
Selection dialog box

3 Click OK
4 Add:

* 3lines
« 1 textbox: Chemtech AG
« 1 textbox: Gartenstrasse 1D-80807 Munchen

¢ 1 textbox: R20 : Harmful by inhalation. S24/25 :
Avoid contact with skin and eyes.

« 1 textbox with the following settings:
» Character tab:
Graphic
Font: CS Symbol 2
Height: 13,20
« Data Source tab:
Fixed Data
Value X
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« 1 textbox with the following settings:
* Character tab:

Graphic

Font: CS Symbol 2

Height: 13,20

 Data Source tab:
Fixed Data
Value F
¢ 1 textbox: F
¢ 1 textbox: Xn
« 1 Barcode:

Graphic

Symbology: QR Code

Height: 13,20

*1 Form:

Input tab: Name: Serial
Variable value: 13R65654

Output tab: Maximum Length: 8

« 1 Form:

Input tab: Name: TagData
Variable value:
5435645T6546345RT54

Output tab: Maximum Length: 25

And place them as in the RFID. lab sample label

5 Go to the Page Setup dialog box by clicking on the Page
Setup icon and select the RFID tab

6 Select the Philips I-Code (depending on the printer you
have selected, this tag model may not be available)

7 Set the Top millimeter at 18 and the Left millimeter at 4
8 Click OK

A new window opens allowing the user to set or define
parameters for different block areas.

9 Set the Data source of Block #1 (Serial Number) to
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Serial. You will see that the value of this block will
populate with the value of the Serial Form. In ASCII
format, each block can only hold 4 characters of
information. So, when you click on block #2, a window
will pop-up asking if you would like the row to be
replicated across 1 more block in order to complete the
information across the next block. If you click the check
mark, the last remaining 4 characters of the Serial form
will automatically populate Block #2, if not, the last 4
characters will not be registered in the RFtag.

10 Set the Data source of Block #3 (Special Function) to
TagData. This will populate the value of Block #3 with
the 4 first characters of the TagData form (5435). When
you click on the block #4, the Row Replication Range
pop-up window will ask if you would like to continue the
information across the following 6 blocks. This will
include the last 15 characters (645T6546345RT54) plus
6 empty spaces (since in the Form settings, the Output
has been set to a maximum of 25 characters)

RFTag programming settings by clicking the
Objects tab in the Document Browser and right-
clicking on RFTag

Q You can quickly access the Page Setup or the

11 Click OK

12 Go to the Print dialog box and click Print
Printing Options

Print Preview Preview your label by clicking on the More >> in the Print
dialog box. An expanded version of the Print dialog box will
open. To preview your label, click on Preview. A new
window will open showing you your label with data. Scroll
through the records using the Previous and Next buttons,
or print directly from this window.

Customizing It is possible to define/customize the Print dialog box to
your Printing simplify the printing process allowing the user to print
directly without being prompted, to print or not to print the
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Printing a
specific record

objects found partially outside the label, or to default to the
direct printing method when a database connection cannot
be found and the print options have been set to Database
Query Result or Search in Database.

To change any optins, you must;

1 Goto File > Print > More > Options.

You can search for a record using the Go To button | .} |
available in your toolbar and print the label directly from the
Go To dialog box. To do so,

1 Click on the Go To button available in your toolbar.

2 Select a Database, a search Field and enter a Value to
search from

3 Clickonthe = arrow to go to the found record (or the
Next record)

4 Print using the Print button.

Optimizing printing

An increasing number of printers come equipped with a
parallel port, and we would recommend using this rather
than the serial port. If you want to print bitmap images,
graphics or Windows TrueType fonts, using the parallel
port will greatly enhance your system’s performance in
terms of data transfer capacity. Moreover, there is only one
type of cable for all parallel links, whereas there is no
standard for serial cables. You thus avoid any problems with
printer cable requirements.

That said, given that many printers are still supplied with a
serial link only, this section also covers most of the problems
you are likely to encounter with serial communications, and
explains how to configure Windows for trouble-free printer
communications.

Furthermore, it is important to bear in mind that Windows
printer drivers, and the program you use for printing, do not
control serial communications between your computer and
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the printer. The communication mode is controlled by:
¢ your printer’s settings;
« the type of serial cable used,;

e the serial communication settings used in the
Windows control panel.

Optimizing As we have already seen in the introduction, there is no
printing speed universal configuration for optimizing printing speed, but
rather a range of different settings that come into play. In the
next example we will look at each of these in turn, hopefully
giving you a better understanding of your own configuration,
and thus enabling you to find the best settings for optimized
printing.
For improving printing speed, there are four basic principles
we need to bear in mind:
« use the parallel port wherever possible;

e use printer objects (fonts, barcodes, and so on)
wherever possible;

« in the case of a serial link, and if the printer offers the
option, make use of the Windows Font Downloader.
This plug-in tool allows you to download any Windows
font into the printer's memory—aquickly and simply—
thus turning it into a printer resource. For more
information on this plug-in (provided with your
application), refer to the documentation available on
the application CD-ROM,;

« use the "Send modified data only” command,
available for the vast majority of printers and available
in the Printer settings dialog box;

The Direct access option is offered when configuring the
printer driver and selecting the port. The table below lists
when this option may be used:

Serial yes yes
Parallel yes yes

Network no yes
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Using this option will depend on your particular
requirements :

¢ In Direct access, the printer driver communicates
directly with the printer: the user has no control over
events until printing is completed (possibly involving
something of a delay);

« Without the Direct access option, the printer driver
transfers data to a print queue, which manages
communication: the user regains control once all data
has been transferred to the print manager (involving
much less of a delay).

Parallel link and serial communication

Given the many advantages of using images, such as the
wide variety of Windows graphics, you will get significantly
better results by using a printer equipped with a parallel
communications port. The majority of standard thermal
printers are equipped with a serial link only (RS 232), with
the parallel port as an optional feature.

Serial communication works fine, as long as you are only
intending to print printer objects (barcodes, fonts, and so
on). If you wish to print bitmap images, printing speed will be
greatly reduced.

For printing images, use the parallel link wherever
possible.

For printing images...

For example, your company logo, not a printer object, must
be transferred to the printer. The more images you send to
the printer, the slower printing becomes—especially if you
are using a serial connection. The solution is to send the
image in question just once, when printing of the label series
is first launched.

The majority of printers allow this operation.

Use the Send modified data only option: the image is sent
to the printer only once, when printing starts, which can take
a little time. However, once the first label is printed the data
transfer process runs much faster, improving performance
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for printing a number of label series.

The label background is stored in the printer’s memory.
As aresult, the fixed image does not need to be
transferred via the cable once the first label is printed.

Substituting TrueType fonts

The TrueType font substitution will be used at the time of
printing to dynamically change a TrueType font to a printer
font. The purpose of this feature is to allow the user to
design a single label that can be printed on different kinds of
printers; using the TrueType font substitution option, the
same TrueType font at design time will be redefined with
the best possible printer font at the time of printing to
optimize the print speed.
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Troubleshooting

Nothing is printed

Page is not
printed

The table below lists the problems most frequently
encountered during printing, and offers some solutions to

help you resolve them.

The printer is not
plugged in.

For a parallel link :
- The printer is not
configured for a
parallel link.

For a serial link:

The serial
communication
settings are incorrect.

The serial cable is not
suitable.

In both cases (serial or
parallel):

- The cable is
connected to the wrong
port.

For direct thermal
printing : the print
media has been
inserted the wrong way
round (the print head is
heating the wrong side
of the paper).

Plug the printer in.

Make sure that this setting has
been configured in the printer
control panel (refer to the
manufacturer’'s handbook).

Make sure that the
communication settings
between the PC and the
printer are the same (for the
serial communication settings
required by the printer, refer to
the manufacturer’s handbook).

Make sure that the cable
matches the specifications of
your printer (refer to the
manufacturer’s handbook).

Check the connection.

Reinsert the media the right
way round.
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A graphic object
(image, Windows
font, graphic
barcode, etc.)
has not been
printed.

The thermal
printer is jammed

For thermal transfer
printing : The ribbon
has not been inserted,
or was inserted
incorrectly.

The required print
mode has not been
selected on the printer.

The printer is out of
memory.

The printer does not
have enough memory.

Some printers will not
recognize an object if it
overlaps the edge of
the printable area,
even by only a few
millimeters.

The print media used is
not the same as the
one defined in the
Page setup dialog box
(continuous paper or
with gap).

Check the ribbon and refit if
necessary (refer to the
manufacturer’s handbook).

Check that the print mode
(thermal or thermal transfer)
has been correctly selected on
the printer (refer to the
manufacturer’'s handbook) or
in the Printer setup dialog box

Check the Clear memory at

next print time only option;
If the problem persists, check
the amount of memory space
allocated to images (Images

tab of your printer driver).

Increase the amount of printer
memory either by adding an
extra memory card, or by
increasing the RAM (refer to
the manufacturer's manual or
check with the dealer from
which you purchased the
printer).

Adjust the position of the
object on the label.

Check that the right print
media was selected during
page setup: Continuous,
With gap.
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Security Made to Measure

User Manager

User Manager is a tool that allows you to manage access
rights to the label design software. It also allows you to set
up group work strategies by organizing user accounts into
user groups. You can create and/or remove user accounts
with User Manager.

Any changes made to user access strategies will take
effect the next time the user runs the application

There are many advantages to a strategy of working in user
groups. Managing user accounts in this way allows you to
adapt the application to the requirements of your company,
adding extra levels of security according to the different
services, thus guaranteeing the integrity of your documents
and data.

You can use separate accounts for creating, modifying or
simply printing documents.

User Manager allows you to manage access rights to the
various documents by means of user accounts. The
administrator can create as many accounts as required,
each one having its own specific rights. Users can be added
to one or more accounts.

An account entitled Guests is created automatically when
User Manager is launched. It contains no default access
rights.
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The
administrator

Without profile
management

Adding the security plug-in disables all commands
linked to the Password function.

User Manager can only be activated once it has been
configured by the administrator.

A user-friendly interface for optimized management of
access rights...

The interface has been designed to make administering the
different user groups as simple as possible. Presented in the
form of a tree, like Windows Explorer, and using context
menus, drag and drop, and so on, working with User
Manager is totally intuitive. In this chapter, we will take a
closer look at how the User Manager interface works.

User Manager cannot be run without an administrator. The
administrator alone is authorized to manage the various
groups: assigning and removing access rights, adding users
or other administrators, creating groups, and so on.

Who is the administrator?

The administrator is the one who runs User Manager for the
first time.

An administrator is the only one who is authorized to
add or remove another administrator.

The computer on which your label design software and User
Manager are installed does not manage user profiles.

In this case, each time the label design software is
launched, a dialog box is displayed asking for a user name
and password.

If User Manager does not recognize the user, i.e. he/she is
not registered in one of the user groups, he/she will
automatically be defined as a Guest and will thus only be
granted those rights the administrator has assigned to the
Guests account.
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With profile
management

Administration

The computer on which your label design software and User
Manager are installed does manage user profiles.

In this case, User Manager administers the user profiles
declared on the network. When the label design software is
launched, User Manager checks whether it recognizes the
user, i.e. that the user is registered in one of the user
groups. If not, the user will automatically be defined as a
Guest and will thus only be granted those rights the
administrator has assigned to the Guests group as assigned
by the administrator.

If the workstation on which your label design software
is installed is connected to an NT network, the
administrator will have direct access to the names of all
users on the network. This reduces the risk of creating
users with incorrect names.

In this section, we will look at all the various functions
available in User Manager.

Adminigrator acoount «_ User Manager S[= B3
Lser Rights Help
-] Administators =B Document
Guet aooourt () Guests 5 New
= Profile 1 « Dpen
® e

Use aooourt

fint) Import
(i) Close

i) Save

L) Saveas

) Export as a printer object fle (POF)

Figure 18 User Manager
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Adding a user

Adding a new
profile

To add a new user to an existing profile:
* Choose User New User.

A new branch is created within the profile, allowing you to
enter the name of the new user, see below:

= profil

...... g_l Ly pont

Figure 19 Adding a new user

Adding a new profile allows you to define the various rights
associated with a particular area of activity within your
organization.

To add a new profile:
1 Choose User New profile.
The new profile is thus created.

2 Give it a name, and configure its rights, see below.

By default, a new profile is assigned all rights.

To define a new profile:

As we have already seen, when a new profile is created, all
rights are assigned to it. The administrator can then remove
those rights that do not apply to the profile in question by
simply clicking on them with the mouse.

To delete a group of rights:

« Select the group of rights to be deleted then choose
Rights Delete.

The group disappears from the tree.
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To delete specific rights:

« Click on the group of rights to be modified then click on
the individual rights one by one with the mouse to
disable them.

To move a user from one account to another

« Select the user, then drag and drop it into the new
account.
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CHAPTER 7

Appendix 1 - Formulas

Calculations with Formulas and Functions

Your software offers a wide range of calculation functions,
allowing you to carry out date calculations, character string
manipulations, and so on. A formula can contain variables,
constants, functions, operators, and so forth.

To carry out such calculations within a document, you will
need to create a variable: the Formula variable.

With its own specific dialog box, this variable allows you to
define the required function(s) for a given formula.

You can create as many Formula variables as there are
calculations to be carried out in your document.

This appendix is complemented by numerous examples that
will help you to put the various types of formulas into
practice. The examples entitled Practical Workshop come
in different levels of difficulty, as indicated by the following
icons:

ooy Very easy

Py Easy

— Difficult
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Different Types of Formulas and Operators

Numerical Calculations are carried out on numerical values and give
formulas numerical results. Values can be either variables or
constants.

2*VarQ = 14
@ The variable VarO refers to the value of a batch

number; 2 is a constant. The result varies
according to Var0, but is always the value of Var0

multiplied by 2.
Logical Logical formulas allow you to check whether or not one or
formulas more conditions have been met.

VarO>Varl

This formula checks whether the value of Var0 is
greater than that of Varl. If yes, the value retur-
ned will be 1 (true), if not it will be O (false).

Text formulas Text formulas involve characters that are, strictly speaking,
not part of the calculation, but which generate the character
strings.

"NOM: "&Var0
The result obtained is NOM: Smith if Smith is the
value of Var0.

About functions  Functions are ready-to-use formulas, which sometimes look

rather complicated. A function can be integrated into a
formula.
A function uses values and arguments to generate new
values. It is not necessarily a case of performing a
calculation in the strict sense of the word, rather logical
analysis or manipulation of character strings, for example.
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Operators

There are six groups of functions in the formula definition:

« check digit calculation functions;
« conversion functions;

» date and time functions;
« logical functions;

» mathematical functions;
« character string functions.

Calculations are carried out in a strict order of priority, which
is why it is sometimes necessary to enclose certain
elements of the formula in brackets to indicate, or change,
the order in which operations are carried out.

Arithmetical operators

AN

%

572 =25

20%3 = 2

5*2 =10

6/2 =3

20+5 = 25

20-5 =15

Text operators

&

<>

“string1”&"strin
g2

VarO=Varl
VarO>Varl
VarO<Varl

Var0>=Varl

VarO<=Varl

VarO<>Varl

exponent 1
modulo 2
multiplication 3
division 4
addition 5
subtraction 6
concatenation 7
of two strings

equals 8
greater than 9
less than 10
greater than or 11
equal to

less than or 12
equal to

different from 13
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The priority rating indicates how the application works when
different operators are combined in the same formula. In the
following formula:

4+5*6-9/2
@ First the multiplication is carried out (5*6), followed

by the division (9/2), then the addition (4+30), and
finally the subtraction. The result would be
remarkably different if the correct order of priorities
had not been followed. The result of the calculation
is 29.5, whereas if the calculation had been carried
out in the order it is written, the result would be
22.5. When two operators have the same priority
rating, the calculation is carried out from left to
right. Brackets allow you to isolate certain
calculations. For example:

(4+5)*(6-9)/2

Gives -13.5, and not 29.5

Creating a Formula

The value of a Formula variable is determined by a
combination of operators, constants, variables, formulas
and functions. The result can be numerical, alphabetical or
alphanumerical.

Formula dialog The Formula variable dialog box allows you to enter the
box expression. The dialog box is divided into three tabs:

*Formula: allows you to determine the characteristics of
the formula;

« Output: allows you to adjust the final formatting of the
variable for display in your document (see Online Help
Output tab);

« Counter. allows you to assign the variable a Counter
attribute (see Online Help Counter tab);

To access the Formula variable dialog box:

1 In the Data Sources tab of the Document Browser,
select Formula.

2 Choose Add...in the context menu.
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A sub-branch called Formula0 appears.
3 Select it and double click.

The Formula dialog box appears (see Figure 19).

Formula0
Farmula I Dutput] Countsr|
Formua editbox — El
Information message regar
ding the syntax of the func , | - |
tion selected
List of the difierent types of IR s Tet |
element that can be inclu Ehock charact 7]8]s
Conversion Undo
ded in aformula Date & Time nEah _—I
— | Hath Inzert |
List ofthe elemerts contzi Ton SR R
nedin the type selected Vst E )
ok I Cancel I Help I
Figure 20 The Formula dialog box
Defining the The first step involves creating the expression that defines
formula the formula.

You can enter elements into the formula edit box either by
typing them in directly using the keyboard, or by selecting
them on screen with the mouse.

To enter the expression:

1 Select the elements that make up the expression one by
one, clicking on Insert to add them to the expression.

2 Once you have finished entering the expression, click on
the Test button. This allows you to check whether there
are any errors in the syntax of the expression.

3 Click on OK.
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To rename the variable:
* To rename a variable, select it, click on it once to select
the default name, then enter the new one.
- or -
press THE F2 button and enter the new name.

To create the variable object and insert the Formula into
the document:

« Click on the Text generation tool, select the formula
then drag and drop it into the workspace.

Do not forget to select the Content view mode in
@ order to check the result of your formula.

If the result is truncated, check the settings in the Output
tab: the maximum length value may be too low to display the
full result of your formula.

: The Online Help provides an exhaustive list of all
?’ the functions, and provides explanatory notes and
examples specific to each one.
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Practical Workshop 1 — Complex Formulas (Ej

-

——.
Logical You can use logical functions to check whether or not one or
functions more conditions have been met. For example, you can use

the if function to determine whether or not one condition has
been met: one value will be returned if the condition has
been fulfilled, another if it has not.

designed for labeling boxes. It contains a name
and address, plus information on the contents. All
boxes for shipping need to be numbered, up to and
including the total number of boxes in the series, a
value determined in advance. Box numbers are
entered manually using the Form when printing is
launched. To check for possible errors, a formula
displays an "ERROR” message when the box
number (BOX# variable) is greater than the total
number of boxes in the series (TOTAL # OF
BOXES variable).

@ The example below presents a document

1 Open the overRRUN.TPL label located in the TUTORIAL
folder.

2 ChooseFile Print...then launch printing by clicking on the
Print button.

The Form appears. We will now enter a value for the BOX#
variable deliberately greater than the TOTAL # OF BOXES
variable, set at 11.

3 Enter "12", then click on OK in the Form.

You will notice that the printed label contains the message
"ERROR” (see the following Figure).
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J P I_ Just-In-Time

Deliver
neme: |[Ejieroven | ROUTE:
Phone: E)364-1271 @

Locatiorrgnq 244

gzardc R al: N
Qty:

Box:

[l ’QQDM\“ ”HWH

9900056

Figure 21 The example label

The formula that displayed this message is the following:

if(value(BOX #) >valug(TOTAL # OF BOXES),"E\n R\n R\n
O\n  R",”")(/n: new ling)

The IF function

Returns one value if the condition you specify is TRUE, and
another value if it is FALSE.

Use the if function to carry out a conditional test on values
and formulas.

Syntax

if("expr”,"val_if_true”,"val_if_false”)

"expr” represents any value or expression, the result of
which can be TRUE or FALSE.

val_if_true is the value returned if "expr’ is TRUE. The
val_if_true argument can be another formula.

val_if_false is the value return ed if "expr” is FALSE. The
val_if_false argument can be another formula.

It is quite possible to link a number of if functions such

as «val_if_true» and «val_is_false» to create more
complicated tests (see example below).
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@ ift dayofmonth = 10,

if{ dayofmaonth = 15,
H{daynfmanth =25, "Risk of heing cut afft","Pay
the bill nowe!™ ),

“Think abaut paying e Dilll™),;
“Evartirg’s fing!”)

O, in English:
“If dayofmonth = 10 then
Ifi davofmondh = 15 den
IF dgvofmonth > 25 then
| Risk of baing ot off!
I niot
Ray the hill Foesl
If ok
Think azout paying the kil
If ot
Evarythng’s fine!”

This example tests the day of the month:

- If the day of the month is between 1 and 10, the message
"Everything’s fine!” is displayed,;

- if the day of the month is between 11 and 15, the message
"Think about paying the bill!” is displayed;

- if the day of the month is between 16 and 25, the message
"Pay the bill now!” is displayed,;

- if the day of the month is greater than 25, the message
"Risk of being cut off!” is displayed.

formula edit box. Do not forget to create the
intermediate variable "dayofmonth” first.

This intermediary variable is created in the Free
branch Data Sources tab of the Document
Browser).

In order to ensure that messages are displayed in
their entirety, enter a value of at least 22 in the
Maximum length box in the Formula dialog box
Output tab.

@ If you wish to test the above formula, enter it in the
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| The Online Help provides examples for all the logi-
?' cal functions available in your software (see
Online Help Logical Functions).

Practical Workshop 2 Calculating a Specific

i

"Modulo” (f:

Method for
calculating a
check character

Your software comes with integrated modulo calculation
functions for generating barcode check characters.
However, it may be that you need to calculate a specific
check character, and, as a result, the integrated functions do
not meet your requirements.

You will thus need to create the function yourself.

In the next sequence we will see how it is possible to use
formulas to create any kind of check character calculations.

This example illustrates how a control character can be
calculated for a 2/5 interleaved barcode.

The method involves multiplying the first character of the
data string by 1, the second by 2, the third by 1, and so on.
* Open the label named cHeckoz.Laslocated in the TutoriaL
folder.
The check character calculation will be carried out on the Lot
Number data.

To calculate the weight

1 Click on the Formula branch of the Document Browser
Data Sources tab, and add a new Formula.

2 Enter the following formula:
mid(LOT NUMBER,1,1)&
mid(LOT NUMBER,2,1)*2 &
mid(LOT NUMBER,3,1)&
mid(LOT NUMBER,4,1)*2 &
mid(LOT NUMBER,5,1)
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The result is 2120103; so we have:

2*1=2

6*2=12

0*1=0

5*2 =10

3*1=3

The concatenation of the results gives 2120103.

3 Name the formula "WEIGHTED".

To add the result of the weight calculation:

The following steps involve adding together the figures
resulting from the previous formula.

1 Create a second Formula, and name it "SUM”.

2 Enter the following expression in the text box:
mid(weighted,1,1)+mid(weighted,2,1)+
mid(weighted,3,1)+mid(weighted,4,1)+
mid(weighted,5,1)+mid(weighted,6,1)+
mid(weighted,7,1)

The result is 9; so we have:
2+1+2+0+1+0+3= 9.

To calculate the check character:

Using the previous result, we will calculate the value of the
check character.

1 Create a third Formula, and name it "CHECK DIGIT".

2 Enter the following expression in the text box:
if((sum % 10)>0,10-sum % 10,0)

The result is 1; so we have:

sum % 10 = 9 (% = modulo).

9 being greater than 0, we carry out the subtraction:
10-9=1.

If the result had been equal to 0, the value of the check
character would have been 0.
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To calculate the data to be encoded:

Creating the barcode must include the data to be encoded,
i.e. the value of the "LOT NUMBER” variable concatenated
with the check character (CHECK DIGIT).

1 Create a forth Formula, and name it "DATA”".

2 Enter the following expression in the text box:

LOT NUMBER & CHECK DIGIT.
The data to be encoded is now:

260531

i Check character

Diata

To create the barcode:

1 Click the Barcode tool on the design toolbar. Next, select
the DATA formula, then drag and drop it onto the label.

2 Select the barcode and choose Object properties... from
the context menu.

The Barcode dialog box appears.
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Figure 22 The Barcode dialog box

3 Configure the dialog box so that it looks like Figure 21.

The label is now finished. The label stock is located in

TUTORIAL\CHECK.TPL.
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Practical Workshop 3 — Date Calculations (»*

Calculating an
expiry date
using the
system date

e

Your software includes an option that allows you to add a
fixed or variable time period to the system date. This
function is extremely useful for calculating the use by date
of a product, for example.

We will now create a label containing two Date variables.
The first for the date of manufacture, the second for the
expiry date.

To create the Date variables:

1 Using the Document Browser Data Sources tab, select
Date.

2 Click on Add... in the context menu.

A sub-branch Date0 appears.

3 Select it and press the F2 key to rename it.

4 Enter DATE OF MANUFACTURE.

5 Select it again, and double-click.

The Date dialog box appears (see Figure 1).

6 Click the 03/June/1998 date format.

7 Click on OK.

We now need to create the EXpIRY DATE variable:

1 Repeating the above procedure, create another Date
variable, and name it EXPIRY DATE.

2 Display the Date dialog box by double-clicking ExpIRY
DATE.

3 As for the DATE OF MANUFACTURE, insert the 03/June/1998
date format.
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Let us say that the shelf life of this product is one year and
two days, i.e. 367 days. After that, the product will no longer
be fit for human consumption.

4 Select theOptions tab, check the Fixed option in the Add
avalue box and enter 367.

5 Select Days as the Unit, then click on OK.

Both variables have now been created, all that remains is to
insert them into the document (see Figure 22).

I SystDate.Lab M=

o ‘m |2n | ‘30 |4n |sn &0 |?n H
b oo bl b b b b b bl b b
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Calculating an expiry date using the
system date.
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Date of manufacture: 25/08/00
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o
L

EXPIRY DATE: 27/08/01

o
L

)
=l

|
E

Figure 23 Calculating an expiry date

The label is now finished. The label stock is located in
TUTORIAL\sYSTDATE.LAB.
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i =y

Practical Workshop 4 — Date Calculations (**’

Calculating an
expiry date
using a non-
system date

i

In this section, we are going to reproduce the same
document without using the system date. Let us suppose
that the operator enters the date of manufacture just prior to
printing the label. This method means that the expiry date
must be calculated using the date of manufacture.

A number of formulas will thus be required to create the
document. All calculations will need to be carried out using
days as the unit of measurement.

The main functions used will be day(), month(), and year().
The method involves adding a time period to the day, month
and year.

These three functions extract the current day, month and
year if the argument is a system date, i.e. today(). However,
they can also return the same result if the argument entered
is the number of days elapsed since a reference date (see
the example below).

Thus day(0)&"/"&month(0)&"/"&year(0) returns the
@ result:

30/12/1899 = your application’s reference date.

If you want the formula to return the current date,
the solution is to calculate the number of days
elapsed since the reference date.

The formula must contain the sum of: " 99*365 =
total number of days for 99 years of 365 days;

" quotient(99-1.4) = number of extra days for leap
years;

" +1 = allows you to set the reference date at 31/
12/1899 so as to start at a date minus one day;

" + the number of days elapsed during the current
year, let us say that it is 20 January 1999.

The expression is thus: day(99*365+quotient(99-
1.4)+1+20)&”"/"&month(99*365+quotient(99-
1.4)+1+20)&"/"&year(99*365+quotient(99-
1.4)+1+20) and the result is 20/01/1999, which is
the current date we have taken for this example.
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To create the intermediate variable required for entering
the date of manufacture:

We will start by creating the variables on which we will base
our calculations.

1 Create a new document.

2 Add an intermediate variable (Form branch), and rename
it Date.

3 Configure the properties dialog box for this variable with
the following values:
- select the Localoption;
- enter "28021999" as the date of manufacture in the box;
- check the Delete spaces box;
- select the Form tab and type ##/##/#### as the Input
format.
- enter 8 as Minimum length.
- select the Output tab and enter "8” as the Maximum
length.

4 Click on OK.

To create the Var variable for entering the shelf life of
the product:
* Repeat the previous steps, modifying the parameters
as follows:
- enter "SHELF LIFE days” as the variable name;
- select the Local option;
- enter 367 in the edit box as the value for the shelf life;
- check the Delete spaces box.

To create the Day, Month, and Year intermediate
variables:

These three variables are extracted from the Date variable,
i.e. the date of manufacture. As we shall see later, they will
be required for calculating the expiry date.

1 In the Document Browser, create a Formula variable,
and name it DAY.

2 Enter the following expression in the formula edit box:
left(date,2): this function extracts two characters from the
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Date argument, starting from the left. Given that the
current value of the Date variable is "28021999", this
formula will thus give a result of "28".

3 Click on OK.

4 Repeat the previous step to create the Month Formula,
entering the following expression: mid(date,3,2).
This function returns two characters, starting from the
third character in the Date string, thus giving a result of
02.

5 Click on OK.

6 Repeat the previous step to create the Year Formula
variable, entering the expression: right(date,4)-1900.
This function extracts four characters from the Date
argument, starting from the right. This gives us a result of
1999. Subtracting 1900 makes it possible to work with
three digits instead of two for Year 2000 compliance.

7 Click on OK.

The result of this formula cannot be used directly. We
will discuss how to employ it a little later on.

To create the intermediate variable for calculating the
number of days elapsed during the current year:

The last element to be determined is the number of days
elapsed in the current year. This variable will allow us to
calculate this number, also checking whether or not the
current year is a leap year.

In order to create this variable, we must first create an
intermediate variable which we will call daystring. This
variable will include a character string defining the number
of days in a year of 365 days. The trick is to add the number
of days elapsed to each consecutive month, starting from 1
January (see below).

000 031 059 090 120 151 181 212 243 273 304 334
Jan Feb Mar Apr May Jun Jul Aug Sep Oct Nov
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1 Using the Free data source, create the intermediate
variable daystring.

2 In the variable dialog box, enter the above string
(000031059090120151181212243273304334) as the
Local value, without including any spaces.

3 Click on OK.

The daystring variable will be used to calculate the number
of days elapsed since 1 January of the current year. We now
need to create the formula that will carry out this calculation.

4 Using the Formula tab, create a variable and name it
Julian.

5 Enter the following expression into the edit box:
day+mid(daystring, (month-1)*3+1.3)+if(and( (month >
2),(mod(year,4)=0)),1,0)

DAY this is the day of manufacture (the variable we defined
earlier).

mid(daystring,(month-1)*3+1.3): the formula allowing us
to extract from the

DAYSTRING Vvariable, the characters corresponding to the
month preceding the month of the date of manufacture.
ifand( (month > 2) ,(mod(year,4)=0)),1,0): allows us to
check whether the current year is a leap year, in which case
if the date of manufacture is after February, an extra day
needs to be added.

Since the date of manufacture in our example is the
28021999, 31 + 28 = 59 days have passed since 1 January.

The Julian formula thus confirms this result.

To create the formula for calculating the expiry date:

All the elements are now in place for defining the expression
that will calculate the expiry date.

1 Create a formula, and name it Expiry date.
2 Enter the following expression into the edit box:

right("00"&day(year*365+quotient(year-1.4)+1
+julian + EXPIRY days ),2)&"/"&
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right("00"&month(year*365+quotient(year-1.4)
+1+julian + EXPIRY days),2) & /" &
right(year(year*365+quotient(year-1.4)+1+julian +
EXPIRY days ),4)

As we have already seen in the introduction to this example,
the functions that allow such calculations to be made are :

- day ("days elapsed in the last year -1” + "product life span
in days”) and;

- month("days elapsed in the last year -1" + "product life
span in days”) and;

- year("days elapsed in the last year -1” + "product life span
in days”).

In our example, the ExpIRY DATE given will be 01/03/2000.

The label we have just produced is also available as a
sample label in the TUTORIAL\labels\exprdate.tpl
folder.

When a number of different people are involved in
developing a document, it can be very useful to
include certain comments so that each user
understands the reasons why a given calculation
has been included. The entire area outside the
borders of the label is non-printable, allowing you
to insert, among other things, the necessary
explanations and comments.

Q Adding comments so that everything is clear.

further examples of all the functions used in this

?_ The Online Help provides full information and
example.
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Appendix 2 - Connecting to
databases

A few reminders

Database

OoDBC

OLE DB

This chapter should give you some idea of just how powerful
your software really is. We are now going to link your label
(the container) with a database (the content) using ODBC
connections(Open Data Base Connectivity) and OLE DB
(Object Linking and Embedding Database).

Databases allow you to store data, which is organized into
two-dimensional tables called a relationship. Each row in a
table is called a record. The purpose of a record is to
manage an object, the properties of which are organized
across the different columns of the table in the form of fields.
A database can contain a number of tables. To link the
different tables in a given database, we use joins. A
concrete example later in the chapter demonstrates how
joins are created.

This is the database access standard. ODBC offers a
straightforward method for linking an application, such as
your label design software, to a number of different
databases.

This is a connection standard for accessing all database
standards and data stored in messaging systems.
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Multiple
Database
Connection

To sum up...

The software provides a number of ODBC drivers, offering
you access to the very latest databases. The drivers are
listed below:

« Microsoft Access Driver (*.mdb)

« Microsoft Excel Driver (*.xIs)

« Microsoft FoxPro Driver (*.dbf)

. R

You can connect your labels to several databases using any
of the methods described in the following workshops. A
drop-down box is available in your Merge Database
Browser toolbar allowing you to easily select and switch
from one database connection to another. Once saved, all
database connections will remain available to that label
whenever it is opened. Each label must have its associated
database connections configured and saved to it.

What is a database? A database allows you to store data in

How do
database?

the form of tables. A table contains
records that allow you to manage
objects, the properties of which are
organized across a number of fields.

I access a By using ODBC or OLE DB.

Where does the data come From an ODBC data source.The data

from?

source includes all the necessary
information  for accessing the
database, such as its name and
access path, and the type of database
engine associated.
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Practical Workshop 1 - Installing an ODBC Data
Source and Importing Data

Installing the
ODBC data
source

Before the data can be accessed, the first step involves
installing the necessary data source.

This first example demonstrates how to install a data source
for an Access database.

To install the data source:

1 Open the Recto_00.tpl label located in the product
installation folder \TUTORIAL\labels.

Itis a sleeve for a CD containing the title of the work and the
tracks recorded.

The data to be inserted into the label is located in the
database entitled Volmusic.mdb.

2 Goto Data source > Databases > Create/Edit query...
The ODBC query definition dialog box appears.
3 Click on _I to the right of the Select a data sourcelist.

The ODBC data source administrator dialog box appears.

ODBC is a component completely separate from your label
design software. You can also access the ODBC data base
administrator via the Windows control panel: choose Start
Settings Control panel and click on the icon below:

&

ODEC

4 In the User DSN tab, click on Add..., then select the
Microsoft Access Driver (*.mdb). Click on Finish.

The ODBC installation for Microsoft Access dialog box
appears.

5 Enter a prompt in the Datasource name box, for example
Classical music source and, if need be, give a brief
description
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Importing data

A data source is now associated with a database. The next
step involves selecting the database we need for our
example, i.e. Volmusic.mdb.

To select the database:

1 Still in the ODBC installation for Microsoft Access
dialog box, click on Select in the Database zone.

2 Select the database located in the installation folder of
your label design software

\TUTORIAL\DATA?F28@A@Z1@Lfr>Volmusic.mdb and
confirm.

3 Close the ODBC installation for Microsoft Access

dialog box by clicking on OK, then exit the ODBC data
source administrator, again clicking on OK.

Online Help is available for each ODBC driver, do
!.- not hesitate to consult it!

Now that the data source has been installed, we can import
the data from the database and insert it into the label.

To import the data:

1 If the ODBC query definition dialog box is not displayed
on the screen, choose Merge Create/Edit query...

2 Choose Classical music source from the Select a data
source list, then select the volumes table.
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The dialog box displays the following information:

Query definition x|
Dl
Database | Sort | e | Filers | options | 500 o |
' ODBC £ OLEDB ™ Include name of tables
Select Data Source Select fields
[Volumes of Ciassical music =] [
Name ofthe data / Select one or several tables :gi;
hack3
source ok Fields
backE
::E&:E \ oon
Lt Yf I
Narme of the tabke oon ?e”et:b";
tained in the database
Cance| Selection
QK I Cancel | Help |
Figure 24 The Defining an ODBC query
3 Click on Select all, then on OK.
All Database variables will now be created automatically
from the fields in the database.
The variables are listed within the Database branch in the
Document Browser Data Sources tab.
4 Save your document.
The application asks you if you wish to save the query.
5 Click on Yes, select \TUTORIAL\QUERY and enter
VoLMusIc.csQ as the query name.
Creating All that remains to be done is to associate the variables we

variable objects have created with an object (text, barcode, etc.) so that they
can appear in the label. For the purposes of our example,
we are going to create variable Text Objects.
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Reminder! It is important to distinguish between
! variablesand variable objects. A variable is a non-
physical object, the value of which changes. A
variable object has a physical appearance (text,
barcode, etc.).

When an object (text, barcode, etc) is associated
with a variable, it is called a variable object.

A given variable can take on different physical
appearances: it can be associated to both a Text
object and a Barcode object at the same time.
Moreover, you can create as many variables as
you wish without creating variable objects. Such
variables can be useful for creating formulas, for
example. We will look at this later on in the chap-
ter.

To create the variable text object ”"Instrument”:

1 In the label, select the fixed text "Title” (the whole text
must be highlighted).

2 Goto Object properties... in the context menu.
3 Click on the Data source tab.

4 Check the Variable data option, then select the Instrument
field located within the Database (18) branch.

5 Click on OK.

You have just changed a fixed object into a variable object.
« To view the different values that the object can take,
use the Navigation bar.

You will notice that the variable object takes the following

values respectively: “The Oboe”, “The Flute”, “The Horn",

“The Harpsichord”, “The Piano”, “The Trumpet’, “The

Organ”, “The Cello”, “The Guitar” and “The Violin”.
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Do not forget to click the Display field contents
Q button to view the variable values.

To create the variable image "Picture”:

1 Select Picture located within the Database branch of the
Document Browser.

2 Drag and drop Picture into the document.

A context menu appears.

3 Choose Image.

The image appears on the screen.

4 Select it and choose Properties from the context menu.
5 Click on the Options tab.

6 Check the Other folder option and select the folder
ATUTORIAL\IMAGES, then click on OK in the Image dialog

box.

7 Select the image and position it towards the top of the
document. Readjust its size if necessary.

To create the variable object “N°":
1 Select the Text generation tool, then select the N_
variable located within the Document Browser Database

branch.

2 Keeping the variable selected, drag it into the label and
drop it next to the "Volume:” text.

3 Save your document.
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To concatenate variables :

In order to finish the sleeve we need to create the variable
objects by associating them with the variables Trackl
through Track15.

Using the method outlined above, associating each of the 15
variables to an object, thus creating 15 variable objects.

To save time, and to facilitate data management later, we
will just create one variable object containing all the data we
need.

To do this, we are going to use the Formula variable,
creating an expression which is the concatenation of all
variables: Trackl through Track15.

1 Select Formula in the DocumentBrowser Data Sources
tab, then choose Add... in the context menu.

A FormulaO variable is automatically created.
2 Select it and double click.
The Formula dialog box appears.

3 Select Variables from the list of different elements that
can be included in the formula.

You will notice that Variables contains all the
! variables available in you application for the current
label:

- the application control variables (see NO TAG) ;
- plus the variables you have just created by
merging the document with the Volmusic.mdb
database.

We now need to concatenate the variables Trackl through
Track15. In order to obtain an organized display, we will also
insert text strings containing the track number followed by a
full stop and a space into the formula.

(example: “1. “).
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Creating the
Table lookup

4 Enter the expression: "1. "& trackl & " - 2. "& track2 & " -
3."&track3 &”" - 4. "& track4 & " - 5. "& track5 & " - 6. "& track6
&"-7."&track7 & " - 8. "& track8 & " - 9. "& track9 & " - 10.
"& track10 & " - 11. "& track11 &” - 12. "& track12 & " - 13. "&
trackl3 &” - 14. "& track14 & " - 15. "& track15

5 Click on OK.
6 Name it "Tracks”.

We now need to associate the Tracks formula variable to a
Text object so that it can appear in the label.

To create a variable Text object:

1 Select the Text generation tool, then the Tracks formula
variable.

2 Drag the formula into the label and drop it below the
Instrument variable.

not forget to select the Value view mode.
Moreover, if the variable value is truncated, check
the display settings in the Output tab of the
variable’s dialog box. Enter 255 in the Maximum
length box.

Finally, to make a paragraph of several lines,
check the Wordwrap option (Paragraph tab of the
Text dialog box) and adjust the size so that it fits
nicely into the lower half of the sleeve.

Q If you want to view the content of the variable, do

3 Save your document.

The Table lookup variable allows you to search for specific
data in a database or table other than the one merged with
the current label.

It may be, for example, that certain object properties are
stored in another database. Storing data in different
databases or tables makes them lighter and easier to work
with, avoiding data repetition.
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In our example, it happens that the Volmusic.mdb database
only contains part of the data we need. In order to complete
the sleeve, we need the following information: Conducted
by:

This information is stored in a second Access database
called CndtedBy.mdb. This database contains the name of
the conductor who directed the recording of each volume.

To create the Table lookup variable:

1 Select Table lookup in the Document Browser Data
Sources tab, then click with the right mouse button and
choose Add...

automatically created specifying the name of the
data source.

In this way, as many sub-branches are created as
there are Table lookup variables with result fields
originating from different databases.

Q Within the Table lookup branch, a sub-branch is

2 Double-click on the sub-branch.
The Table lookup dialog box appears on the screen.

3 Connect the CndtedBy.mdb database using the ODBC
data source administrator.

4 Once the connection has been made, select the name of
the data source in the Select a data sourcelistin the Table
lookup dialog box.

5 Complete the different fields as shown in the figure below.
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Lists all the variables in the current label. Select the one with the value that will al-
low the result field to be displayed. In our example the key value is the volume num-
ber: N°. This information is also stored in the CNDTEDBY.MDB database and
corresponds to the name of the conductor.

Figure 25 Creating a Table lookup

6 Once the dialog box has been completed, click on OK.

7 Select the Table lookup variable that you have just
created, then click on it once to select the default name and
enter Name.

8 Select the Text generation tool, then, keeping the Name
Table lookup variable selected, drag and drop it under the
"Conducted by” text.

9 Save your document.
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To sum up...

What is a variable ?

What are the different
types of variable ?

Which data sources can
feed these
variables?

What is a variable object?

A variable is a non-physical object, the
value of which advances as printing
progresses. There are different types of
variables. The value of a variable
depends on the type of data source.

There are eight different types of
variables:

- Database

- Table lookup;

- Formula;

- Counter;

- Date ;

- Form ;

- Free.

- Shared.

- The Database variable is fed by the data
contained in a field of the database
merged with the current label.

- The Table lookup variable is fed by the
data contained in a field of a data source
other than the one merged with the
current label.

- The Formula variable is fed by the result
of an expression that can contain
variables, constants, and so on (see NO
TAG, appendix 1 — Formulas).

- The Counter variable is fed by the result
of a calculation carried out by the
computer or the printer.

- The Date variable is fed by the system
date of your computer or printer.

- The Form variable is fed by keyboard
input.

A variable object is a variable that takes
on a physical appearance, whether text,
an image or a barcode.
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Practical Workshop 2 — Complex Queries and

Joins

Constructing an
internal join

In this next sequence, we are going to look at the concept of
queries and joins. To do this, we are going to create the
reverse side of the CD sleeve containing the volume
number, artist's name, tracks list, and track times.

To create the reverse side of the sleeve, we are going to use
a third Access database that holds the supplementary
information we need, i.e. the track times and the artist. This
database is called VolDur.mdb and contains two tables:

« Duration

 Author

The first step involves connecting the new label verso_00.tpl
to the database VolDur.mdb.

To create the data source:

1 Open the label verso_00.tpl located in the
TUTORIAL\labels folder and Go to Data source >
Databases > Create/Edit query....

2 Create a new data source using the ODBC data source
administrator.

3 Name the new source "Duration source”.

4 Once the new source is installed, select it in the Select a
data source list in the ODBC query definition dialog box.
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Figure 26 Selecting the Duration source data source

5 Select the two tables: Author and Duration.

All the fields contained in the two tables appear in the list on
the right hand side.

6 Check the Include name of tables option.
This option displays the source of a given field.
7 Click on Select all, then on the Joins tab.

8 Enter the expression for defining the join as shown in the
figure below.
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Figure 27 Constructing an internal join
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9 Once you have displayed the result of the query (see
below), close the Query result grid, then click on OK in the
ODBC query definition dialog box.

= Query result [_[olx]
3l [P o =] ECN R E )|

AuthorNum | AuthorAuthor | Durstion Track1] Duration Track2] Duration. Track3 | Duration Trackd | Duration. Trar |

1 M. Brach [ [ EH 0500

2 B.Mandelkon | 0545" [ " 02

3 E. Garter [; 050" 045"

4 P. Schmal [ [P 02

5 . Fussman [ 050 o4

E C. windsor o 055" 0z25"

7 T. Jnreszabo 0. o5 500"

E) 4. Charmonis o ‘[IZ'EE 0225"

E] K Nidrat 1045 355" 545"

Ta T Soel 255" [ 500"

U9 Record 1 of 10 1{* M} 4

Figure 28 The Query result grid

The Database branch now displays the 18 variables
created.

10 Save your document and the query, naming it, for
example, VolDur.csg.

In this next sequence, we are going to insert the variables
into the label. We could associate each track length variable
with a Text object, but that would be time-consuming and
laborious. As in the previous exercise, we are going to
create a formula concatenating the Duration variables.

To concatenate the variables:

1 Select Formula in the Document Browser Data Sources
tab, then choose Add... in the context menu.

A FormulaO variable is automatically created.
2 Select it and double click.

3 Select Variables from the list of different elements that
can be included in the formula.

4 Enter the following expression where /n stands for
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carriage return:
“Duration.Track1&"\n"&Duration.Track2&™\n”
&Duration.Track3&"\n"& Duration.Track4&”\n"&Duration.
Track5&™n"& Duration. Track6&"\n"&
Duration.Track7&"\n"& Duration. Track8&"\n"&
Duration.Track9&"\n"& Duration.Track10&"\n"&
Duration.Track11&™\n"& Duration. Track12&™\n"&
Duration.Track13&™\n"& Duration.Track14&"\n"& Duration.
Track15”

5 Name the variable "TrackDuration”.

We now need to associate the TrackDuration formula
variable with a Text object to include it on the label.

To create a variable Text object:

1 Select the Text generation tool, then, keeping the
TrackDuration formula variable selected, drag and drop it
into the document.

2 Save your document.

output settings. The maximum length probably

If the value of the variable is truncated, check the
; needs adjusting.

To complete the reverse side of the sleeve, we now need to
insert the titles of the different tracks opposite their
respective track lengths.

To insert the titles:

1 Create a Table lookup variable in the Document Browser,
and name it Trackl.

2 Complete the dialog box with the following data:
- Select a data source: Classical music source;

- Select table: Volumes;

- Select result field: Trackl;

- Key field : N ;

- Key value (variable): Author.Num.
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3 Repeat the above procedure to create all 15 Table lookup
variables, remembering to select the cor